Music Database Backup

Musicnizer comes with a demo database that shows you main features of the program. Once you decide to organize your music with the program and start adding music albums, it is recommended to create a new database. It's pretty easy. Click "File" - "New database".

Create a new database

In the "Save as" dialog, browse to the folder where you'd like to store your database file and enter some name (for example, "my_music") for the file. It is recommended to save your database in a folder where you can easily access the file. This may be useful if you decide to move to another computer, reinstall the operating system etc.

Of course, it is also possible to continue using the demo database and just add your albums to it.

Create a Backup

There are several ways of creating backups:

  • Use the "File" - "Backup" menu.
  • Copy the database file and the "Covers" folder manually, using Windows Explorer.
  • Click "Yes" to backup prompts like this:

Create a backup of your database

Musicnizer will prompt to create backups automatically every given number of days. This is set in the "Options" menu. The automatic backups are saved to the same folder where your current database is stored. They are ZIP files with the same name as your database file followed by the date when the backup was created.

It is recommended to keep at least 3 latest backups.

Restore Music Database

Depending on the method used to create your backup, you can restore your music database as follows:

  • Use the "File" - "Restore" menu. This will work for backups created automatically and for backups through "File" - "Backup".
  • Double-click the backup copy of your database in Windows Explorer, or use the "File" - "Open database" menu. This will work for manual backups with the help of Windows Explorer.

Free Download

Download Musicnizer
Version 8.1
Musicnizer: the Music Organizer